AlulaConnect.com Service Incident

Incident Report for Alula Service Status

Resolved

This incident is now marked as resolved.
Posted Nov 18, 2025 - 14:39 CST

Monitoring

Access to AlulaConnect.com has been fully restored.

Our engineering team will continue to closely monitor the platform to ensure stability and verify the resolution.

Thank you for your patience during this interruption.
Posted Nov 18, 2025 - 09:07 CST

Investigating

Our Alula Engineering team is aware of the current service disruption preventing customers from accessing AlulaConnect.com.

We are actively collaborating with our third-party partner, Cloudflare, to diagnose and resolve the issue with the highest priority.

We apologize for the inconvenience this is causing. A follow-up update will be provided shortly.
Posted Nov 18, 2025 - 07:54 CST
This incident affected: AlulaConnect.