Alula.com Maintenance
Incident Report for Alula Service Status
Resolved
The maintenance on Alula.com has been completed.
Posted May 18, 2023 - 16:30 CDT
Investigating
Alula.com is current undergoing maintenance and will be brought back online as soon as possible.
Posted May 18, 2023 - 12:39 CDT