Alula Customer Solutions Center Phone Issues

Incident Report for Alula Service Status

Resolved

This issue has now been fully resolved, and our phone systems are operating normally.
Posted Dec 01, 2025 - 15:41 CST

Identified

We are aware that some customers are having trouble reaching our Customer Solutions Center by phone. We apologize for the inconvenience and are working closely with our phone service provider to resolve the issue as quickly as possible.
Posted Dec 01, 2025 - 10:40 CST
This incident affected: Enterprise Support Services (Inbound Calling).