The signal-relay issue affecting PSTN and IP services has been resolved. Services are operating normally.
Posted Oct 21, 2025 - 19:01 CDT
Monitoring
We’ve implemented a fix for the signal-relay issues affecting PSTN and IP services. Alula Engineering is monitoring for stability and will share updates as they become available.
Posted Oct 21, 2025 - 17:25 CDT
Identified
We’ve identified the cause of the signal-relay issues affecting PSTN and IP services. Alula Engineering is working on a resolution and will share updates as they become available.
Posted Oct 21, 2025 - 16:23 CDT
Investigating
We’ve received reports of signal-relay issues affecting both PSTN and IP services. Alula Engineering is aware and actively investigating the root cause. We’ll share updates as they become available.
Posted Oct 21, 2025 - 15:51 CDT
This incident affected: Signal Relay Services (PSTN Signal Relay Services, IP Signal Relay Services).